Subject: Re: cachefs mounts in /etc/vfstab?

From: [email-masked] (Thomas Maslen)
Date: 22 Mar 1994 18:33:37 -0800

[email-masked] (Jim Davis) writes:
...
>#device		device		mount	FS	fsck	mount	mount
>#to mount	to fsck		point	type	pass	at boot	options
...
>server:/opt	/local/cache	/opt	cachefs	2	yes	backfstype=nfs
>
>and try to mount it with 'mountall -F cachefs' (or on a reboot), then
>I get
>
>fsck -F cachefs: Cannot open /cache/.cfs_resource: No such file...
>
>and similar nonsense messages about /cache, instead of /local/cache.

Append ",cachedir=/local/cache" to the mount options.

Thomas Maslen
[email-masked]				My opinions, not Sun(Soft)'s

---

From: [email-masked] (Eckhard Rueggeberg)
Date: Thu, 24 Mar 1994 09:02:06 GMT

In article [email-masked], [email-masked] (Jim Davis) writes:
>Starting with a local filesystem, /local, the commands
>
># cfsadmin -c /local/cache
># mount -F cachefs -o backfstype=nfs,cachedir=/local/cache server:/opt /opt
>
>work, just like the Answerbook says.  But if I add the following,
>apparently equivalent, entry to /etc/vfstab:
>
>Any ideas?

I wouldn't say the vfstab entry is equivalent unless you use the same mount
options, in particular "backfstype=nfs,cachedir=/local/cache" 

---
Eckhard R"uggeberg
[email-masked]