Subject: Re: How to disable Tagged Command Queuing

From: [email-masked] (Dave Johnson)
Date: 2 Mar 1994 15:57:23 -0500

[email-masked] (ron nash) writes:

>A while ago, there was a discussion on how to disable tagged command
>queuing for the Solaris SCSI driver.  Could someone send me the
>instructions for this or post them?

>Thanks

>             ,--, | Ron Nash      San Diego State University
>       _ ___/ /\| | [email-masked]
>   ,;`( )__, )  ~ |  
>  //  //   '--;   | Gin-N-Tonic   endurance horse
>  '   \     |     | Luv on Fire   trusty trail horse

In /etc/system, add the following line and reboot.

set scsi_options=0x178

The default value is 0x1f8, which turns on all the neat features.
The bits are documented in /usr/include/sys/scsi/conf/autoconf.h.
Our problem disk (Fujitsu M2694ESA) stopped giving problems when
we added the patch 101378-02:

> Patch-ID# 101378-02
> Keywords: WIDE scsi negotiation esp driver
> Synopsis: SunOS 5.3: WIDE scsi negotiation and esp driver fixes
> Date: Jan/20/94
>  
> Solaris Release: 2.3
>  
> SunOS release: 5.3

This is a bit interesting as Sun originally claimed the Fujitsu firmware
was at fault, and Fujitsu has a firmware patch to make it compatible with
Solaris....  We didn't update the firmware yet.

	Dave Johnson
	Gradient Technologies, Inc.
	[email-masked]

---

From: [email-masked] (Casper H.S. Dik)
Date: 2 Mar 1994 21:45:12 GMT

>instructions for this or post them?

Tagged command queueing is still giving a number of people
a lot of problems it seems.

The question in the FAQ seems to be in need of an overhaul.

One of the problems we see with tagged command queueing is
that as soon as a tagged command gets lost, Solaris takes a
long long time to recover.  (In the order of 30 minutes).
The system is still usable at that point, but the command
on which behalf the tagged command has been queued hangs.
Other access to the same disk still works.

The solaris FAQ says:

3.25) How do I make Solaris2 use my Toshiba MK538FB drives?

	Append this line to /etc/system and reboot:

	set scsi_options=0x78

	This turns off Command Queueing, which upsets the Toshiba
	and some other drives.  If you have fast SCSI, you must use:

	set scsi_options=0x178

	or you end up disabling fast SCSI as well.

    --- end of excerpt from the FAQ

Warning: the numbers reflect the latest working copy of the FAQ,
they may not match the last version posted

Questions marked with a * or + have been changed or added since
the FAQ was last posted