Subject: Re: Keepalive using tcp/ip

From: [email-masked] (W. Richard Stevens)
Date: Fri, 19 Nov 1993 17:54:13 GMT

> How do you set the keepalive value on solaris 2.x?  I can't seem to work
> our how to build a kernel (if you can).  The keepalive value seems to be
> shown in /usr/include/netinet/tcp_timer.h and is set to (120*60*PR_SLOWHZ)
> where PR_SLOWHZ is 2 (ie twice a second). 

TCP/IP configurable parameters are set/examined using ndd(1).  What you
want is

	ndd /dev/tcp tcp_keepalive_interval

and the value printed is 7200000 (2 hours in ms).  Change that to
whatever you'd like, *but* it's a system-wide parameter and will
affect all TCP connections that set the keepalive option.

	Rich Stevens  ([email-masked])

---

From: [email-masked] (Dave Peterson)
Date: Fri, 19 Nov 93 18:42:21 GMT

In article [email-masked], [email-masked] (Jon Machtynger) writes:
>If you can't build a kernel, and /etc/system is just used on boot, will
>modifying this value change the keepalive (as other things in this
>area) or will an 'update' program need to be run to make this known.
>I would have thought there would be some utility to do this.  Answerbook is
>not too helpful in this area.
>
>Thanks in advance
>
>
>Jon
>
>
>--
>--
>Jon Machtynger ([email-masked])  Tech Consultant (Instn and Perf. Team)
>Ingres Technology Centre. Wharfedale Rd,
>Winnersh, Wokingham. Berks UK.   (0734)-496481

Try:

ndd -set /dev/tcp tcp_keepalive_interval <value>

---
===================================================================
Dave Peterson           phone : 612-493-1008
Senior Engineer 
Network Systems Corp.	email: [email-masked]
===================================================================