Subject: Re: Emacs 19.17 on solaris 2.x

From: [email-masked] (Mike Eggleston)
Date: Thu, 5 Aug 1993 15:31:10 GMT

In article <[email-masked]> [email-masked] (Robert Boucher) writes:

>Runs well here.  Only 'list-options makes emacs crash and burn, but it
>will be fixed in the next release.

I had the same problem with 'list-options and traced it down to the
floating point routines.  In my .emacs file I placed
(setq float-output-format "%.5g") and everything then works fine.
--
--
Mike Eggleston       American Airlines Decision Technologies     
(817)931-2287        P. O. Box 619616, MD 4462                            
(817)967-9763 (FAX)  Dallas/Fort Worth Airport, Texas 75261-9616, USA
Only my opinions.

---

From: [email-masked] (Tom Zepf)
Date: Tue, 10 Aug 93 14:53:15 GMT

In <[email-masked]> [email-masked] (Gerald Hall) writes:

>In article <[email-masked]> [email-masked] (Bill Wisner) writes:
>>>Anyone get the impression emacs 19 is not *quite* ready for Solaris 2.2
>>>yet?  No offense Richard et al - I'm not suggesting you're sleeping nights.
>>
>>Running flawlessly here.

>Details please.  I am running 2.2 with the SunPro (unbundled) (patched to
[ deleted ]

I find the following shell script is all I need to configure for
Solaris. Note that I do not include any UCB stuff in my path, though
I don't know if that makes any difference. As you can see, all I
really do is define the CPP environment variable to point in the right
place, and I use the SunPro compilers, not GCC.

--------------------------- cut here ------------------------------------
#!/bin/sh -x

CPP=/usr/ccs/lib/cpp
export CPP

#dot_h=src/s/sol2.h
#egrep 'SYSTEM_MALLOC' $dot_h > /dev/null
#case $? in
#1)	if [ ! -f ${dot_h}.orig ]; then
#		cp ${dot_h} ${dot_h}.orig
#	fi
#	chmod +w $dot_h
#	echo "#define	SYSTEM_MALLOC	1" >> $dot_h
#	;;
#
#0)	;;
#*)	echo "egrep egrep 'SYSTEM_MALLOC' src/s/sol2.h failed"
#	exit 1
#	;;
#esac

./configure sparc-sun-solaris2.2 \
	--with-x11 \
	--x-includes=${OPENWINHOME}/include \
	--x-libraries=${OPENWINHOME}/lib \
	-with-gcc=no

for file in config.status Makefile src/config.h; do
	echo $file
	if [ ! -f ${file}.orig ]; then
		cp ${file} ${file}.orig
	fi
	chmod +w $file
	sed -e 's/^CFLAGS=.*$/CFLAGS=-O/' < $file > /tmp/XXX
	cp /tmp/XXX $file
done

---

From: [email-masked] (Casper H.S. Dik)
Date: 10 Aug 1993 15:35:32 GMT

>Patch-ID# 100961-02) C compiler and the BSD compatibility package installed.
>I have made a "first pass" at several approaches (with and without the
>solaris_2_1 'hints, and manually trying to exclude the ucb stuff) - to no
>avail (starting from a new extraction from  the .tar file in each case).
>I have cleaned up the '==' problems in Configure and the spaces between
>the '-' and the option chars in the Makefile.  I get lots of "warnings"
>from the compiler and then different fatal errors in each case.

Trick you'll need for SunPRO C:

env 'CC=cc -Xs' ./configure <blah blah>

No LD_LIBRARY_PATH

And don't use ``/usr/ucb/cc''.

Usually, I compile with gcc but I tried it for this once with:

env 'CC=cc -Xs' ./configure --run-in-place

(making emacs only takes 10 minutes, so I thought ...)

Builds and runs fine.

Casper