Subject: Setting up a printer (for ASCII and Postscript)

From: [email-masked] (Jonathan Miner x3065)
Date: Fri, 27 Aug 93 14:01:08 GMT

Hi Folks!

I have an Apple Laserwriter (Postscript) printer and have hooked it
up to my Sparc 10, running Solaris 2.2.  I would like to be able to
send both ASCII (simple) and postscript files to the printer. Right
now only the postscript files will print.

Here is a terminal session:
# lpfilter -f postprint -l
Input types: simple
Output types: postscript
Printer types: any
Printers: any
Filter type: slow
Command: /usr/lib/lp/postscript/postprint
Options: PAGES * = -o*
Options: COPIES * = -c*
Options: LENGTH * = -l*
Options: MODES group = -n2
Options: MODES group\=\([2-9]\) = -n\1
Options: MODES portrait = -pp
Options: MODES landscape = -pl
Options: MODES x\=\(\-*[\.0-9]*\) = -x\1
Options: MODES y\=\(\-*[\.0-9]*\) = -y\1
Options: MODES magnify\=\([\.0-9]*\) = -m\1
# lpstat -p -l
printer lw is idle. enabled since Fri Aug 27 09:48:06 EDT 1993.
available.
        Form mounted: 
        Content types: postscript, simple
        Printer types: PS
        Description: Apple Laserwriter
        Connection: direct
        Interface: /usr/lib/lp/model/standard
        On fault: write to root once
        After fault: continue
        Users allowed:
                (all)
        Forms allowed:
                (none)
        Banner not required
        Character sets:
 
        Default pitch:
        Default page size: 80 wide 66 long
        Default port settings:  
# cat /usr/pub/ascii | /usr/lib/lp/postscript/postprint | lp -o nobanner
request id is lw-44 (standard input)
# cat /usr/pub/ascii | lp -o nobanner 
request id is lw-45 (standard input)

The first lp command works, the second does not.  What am I missing?

Thanks in advance.
-- 
| Jonathan Miner                       |                        |
| [email-masked]    |                        |
| 603-885-3065 <<voice>>               |                        |
| BTW: I do not speak for Lockheed or anybody else. Just me!    |

---

From: c4080@rphs1 (Wolfgang Ratzka t2085)
Date: 27 Aug 1993 15:40:47 GMT

Jonathan Miner x3065 ([email-masked]) wrote:
: Hi Folks!

: I have an Apple Laserwriter (Postscript) printer and have hooked it
: up to my Sparc 10, running Solaris 2.2.  I would like to be able to
: send both ASCII (simple) and postscript files to the printer. Right
: now only the postscript files will print.

: Here is a terminal session:
:
: (...)
:
: # lpstat -p -l
: printer lw is idle. enabled since Fri Aug 27 09:48:06 EDT 1993.
: available.
:         Form mounted: 
:         Content types: postscript, simple
                         ^^^^^^^^^^^^^^^^^^
:         Printer types: PS
:         Description: Apple Laserwriter
:         Connection: direct
:         Interface: /usr/lib/lp/model/standard
:         On fault: write to root once
:         After fault: continue
:         Users allowed:
:                 (all)
:         Forms allowed:
:                 (none)
:         Banner not required
:         Character sets:
:  
:         Default pitch:
:         Default page size: 80 wide 66 long
:         Default port settings:  

This tells the lp service that the printer can understand both
`simple' and `postscrit' input without filtering, which is not true.

--
    _ 
|  | ) 
|/\| \ Wolfgang Ratzka <[email-masked]>