Subject: setting up a printer

From: [email-masked] (Rob Dorich)
Date: Fri, 17 Sep 1993 21:07:33 GMT

Hello netters,

	At this moment we have moved most of our stuff to Solaris 2.2,
and would like to know how to add remote printers (for starters)
completely manually.  I have been able to successfully do this using
admintool (wow! difficult), and the combo lpsystem, lpadmin, and
request.  

	Could some kind person tell me what files are
involved/created when using lpsystem and admin? and request?  I
already tried to setup a remote printer by just adding what I thought
was necessary, but had no luck.  I think that one of the main problems
was that I couldn't tell the lp service that a printer had been added.

	These are my notes on what I did or noticed...

----
Most of files are /etc/lp/*
Systems:
        ss7:x:-:bsd:-:n:10:-:-:
 
default... has default printer (hp)
 
filter.table was changed: weird file.
 
in /etc/lp/printers:
directory per printer is created:
/etc/lp/printers/*/comment      Just a comment
/etc/lp/printers/*/configuration:
 
        Content types: any
        Printer type: unknown
        Remote: ss7             (this is of main interest)
 
In /var/spool/lp/tmp create a dir for each sys where there is a printer.
In /var/spool/lp/requests/ create a dir for each sys where there is a printer.
---- 

I was hoping it would be something as easy as edting /etc/printcap :)
Any help will be welcome,

Thanks,

	Roberto

--

Roberto Dorich	     	  o       SKI		[email-masked]
Electrical Engineering   /=     EXTREME	 	[email-masked]
Tufts University        __/__,           uucp:	[email-masked] 
----------------------------------------------------------------------------

---

From: [email-masked] (Richard Elling)
Date: Fri, 17 Sep 1993 22:35:57 GMT

>was that I couldn't tell the lp service that a printer had been added.

Simple.
	SERVER=...
	SERVER_TYPE={bsd|s5}
	PRINTER_NAME=...

	lpsystem -t $SERVER_TYPE $SERVER
	lpadmin -p $PRINTER_NAME -s $SERVER -I any
	accept $PRINTER_NAME
	enable $PRINTER_NAME

This is *very* easy to roll into a script where you just create a list
of SERVER/SERVER_TYPE/PRINTER_NAME triplets.

>Any help will be welcome,

Ain't nothing as hard as editing /etc/printcap.  What a piece of junk.
You can blissfully forget every little typo, tab/space goofup, missing \,
botched up fc and xc entry you ever made in a printcap file.  With the lp
system, there is no such grief.  No editing files.  Life is good.

Of course, life will be even better when Sun gets the NIS+ printer stuff
working...  it's tauntingly close in SunOS 5.2...

---
 Richard Elling, Manager of Network Support, Engineering Administration
 Auburn University     [email-masked]     kb4hb.ampr.org
 "The world is my lavatory." -- Albert Alligator