Subject: Re: I worry about tcsh

From: [email-masked] (Casper H.S. Dik)
Date: 16 Oct 1993 11:36:05 GMT

[email-masked] (Keith Steiger) writes:

>I ftp'ed to opcom.sun.ca to get tcsh for Solaris 2.2.  First, I got the
>binary; it dumped core.  Then, I went back to get the sources.  I uncompress
>and untar that, and it turns out that the tar file contained a core file.

>I'm not sure I even want to compile this....

We've been running tcsh 6.0.4 from tesla.ee.cornell.edu for
quiote some time now and are quite happy with it.

(You need a small fix to prevent it from eating too much typeahead,
I'll see if I can find that somewhere, if anyone is interested)

Casper

---

From: [email-masked] (Casper H.S. Dik)
Date: 17 Oct 1993 16:07:27 GMT

>I'll see if I can find that somewhere, if anyone is interested)

Since a number of people requested it, here it is:

*** tcsh-6.04/sh.h.org	Thu Jul  8 06:52:56 1993
--- tcsh-6.04/sh.h	Sun Sep 12 13:55:03 1993
***************
*** 270,276 ****
  #define CSWTCH _POSIX_VDISABLE
  #endif
  
! #if !defined(FIOCLEX) && defined(SUNOS4)
  # include <sys/filio.h>
  #endif /* !FIOCLEX && SUNOS4 */
  
--- 270,276 ----
  #define CSWTCH _POSIX_VDISABLE
  #endif
  
! #if !defined(FIOCLEX) && (defined(SUNOS4) || (defined(sun) && SYSVREL >= 4))
  # include <sys/filio.h>
  #endif /* !FIOCLEX && SUNOS4 */