Subject: Re: Patch FTP site [Re: Mandatory patches for 2.2]

From: [email-masked] (Alain Brossard EPFL-SIC/SII)
Date: 16 Sep 1993 09:16:13 GMT

In article <[email-masked]>, [email-masked] (Michael D'Errico) writes:
|> [email-masked] (Himanshu Gohel) writes:
|> 
|> >The best site for Sun patches in the South-East is
|> 
|> >sunsite.unc.edu
|> 
|> >in /pub/sun-info/sun-fixes (please check exact directory name)
|> >This has all Sun patches - Solaris 1.x and Solaris 2.x, and also
|> >for PC-NFS, SunVision, Developer's Guide etc.
|> 
|> Are these really the patches?  Or some subset?  I downloaded patch
|> number 100985-04 (the libc jumbo patch) which is supposed to contain:

    The latest one is 100985-05, available from
sunline.epfl.ch:pub/sun-patches/100985-05.tar.Z

|>         /usr/bin/jsh
|>         /usr/lib/rsh
|>         /usr/bin/sh
|>         /usr/include/dirent.h
|>         /usr/lib/libc.a
|>         /usr/lib/libc.so.1
|>         /usr/lib/libp/libc.a
|>         /usr/lib/pics/libc_pic.a
|>         /sbin/sh
|>         /sbin/jsh
|> 
|> When I unpacked the patch, it only had
|> 
|>         /usr/bin/jsh
|>         /usr/include/dirent.h
|>         /usr/lib/libc.a
|>         /usr/lib/libc.so.1
|>         /usr/lib/libp/libc.a
|>         /usr/lib/pics/libc_pic.a
|>         /sbin/jsh
|> 

   sh or rsh are not in versions -03, -04 nor -05 of the patch, I've just checked.
The fixes to sh, are probably contained in /usr/lib/libc.so.1.  Meaning
the problem was really with libc and was visible from sh (?).  However
this does NOT fix the static version of sh.

   Just checked the README, it does say that /usr/bin/sh and /sbin/sh are
supposed to be included, I guess we should get in touch with Sun to find
out what the problem is.

    Note also that if you use "LANG=fr", sh core dumps so easily it's
not funny.  I never managed to enter more than 3 lines before it core dumped!

-- 

Alain Brossard, Ecole Polytechnique Federale de Lausanne,
    SIC/SII, MA-Ecublens, C.P. 121, CH-1015 Lausanne, Suisse, +41 21 693-2211
[email-masked]

---

From: [email-masked] (Jeff Hameluck)
Date: Thu, 16 Sep 1993 21:44:25 GMT

In article <[email-masked]> [email-masked] writes:
>But there isn't a *real* Sun-approved Patch FTP site, is there?
>
>Tim
>
>---
>Tim Steele, Network Manager, [email-masked].  PGP key available via finger.
>
Yes but you need to have a service contract to have access to it. We have the
SunSpectrum Silver Support package and we have access to the FTP patch
site maintained by Sun.  I don't know about any other support contracts
though.

Jeff Hameluck								[email-masked]
Computer Operations Unit					Regina, Saskatchewan, Canada
Regina Public Library						(306) 777-6057