Subject: list of mandatory Solaris 2.2 patches

From: [email-masked] (Bill Wisner)
Date: Fri, 3 Sep 1993 01:59:14 GMT

I've received many requests to post the list of mandatory patches for
Solaris 2.2.  All these patches can be FTPed from thor.ece.uc.edu or
obtained from Sun support.

Patch-ID# 100985-04
Synopsis: SunOS 5.2: Jumbo patch for libc and other associated fixes
BugId's fixed with this patch: 1113040 1121164 1121751 1130394 1114167

Patch-ID# 100992-02
Synopsis: SunOS 5.2: streams related panics involving local transport drivers
BugId's fixed with this patch: 1121031 1110027

Patch-ID# 100999-21
Synopsis: SunOS 5.2: jumbo patch for fixes to kernel/unix & NFS driver
BugId's fixed with this patch: 1119267 1121146 1123874 1124210 1126184 1129464 1129087 1113596 1123266 1130848 1127302 1122420 1117034 1115068 1131435 1133751 1123178 1126165 1123855 1132273 1131580 1123435 1122465 1132866 1123762 1134196 1134196 1127070 1103091 1137685

Patch-ID# 101014-02
Synopsis: SunOS 5.2: fixes for usr/lib/libsocket
BugId's fixed with this patch: 1124510 1122704 1127186

Patch-ID# 101027-04
Synopsis: SunOS 5.2: fixes for /kernel/drv/tcp
BugId's fixed with this patch: 1120065 1127396 1121957 1084913 1124247 1122464

Patch-ID# 101031-01
Synopsis: SunOS 5.2: The file descriptor limit is too low on inetd
BugId's fixed with this patch: 1112111

Patch-ID# 101090-01
Synopsis: SunOS 5.2: fixes security hole in expreserve
BugId's fixed with this patch: 1134063

Patch-ID# 101109-02
Synopsis: SunOS 5.2: fixes problems with ldtermclose() & ptmclose()
BugId's fixed with this patch: 1130226 1133037 1129615
-- 
Bill Wisner <[email-masked]> Gryphon Gang Mountain View CA 94039-0386

---

From: [email-masked] (Luca Polo)
Date: Fri, 3 Sep 1993 08:25:56 GMT

>obtained from Sun support.

Well, I have applied a number of patches on Solaris 2.2, but there are some
minor differences in some of the patch-IDs (see below).
BTW, what are the meaning of the numbers in the patch-IDs ? It may sound strange,
but I never worried about this topic before. I also imagine that XXXX-YY means
"patch # XXXX, release YY", but I may be wrong.

>Synopsis: SunOS 5.2: jumbo patch for fixes to kernel/unix & NFS driver
I don't have 100999-21, but 100999-22 (same synopsis)

>Synopsis: SunOS 5.2: fixes for usr/lib/libsocket
I have  101014-04
Synopsis: SunOS 5.2: libsocket problems with signals, too many open files,
          non-blocking I/O

>Synopsis: SunOS 5.2: fixes for /kernel/drv/tcp
This is marked to be obsoleted (on my patch-list) by 101018-02
Synopsis:  SunOS 5.2: Jumbo patch for ip and tcp fixes

There's no difference in the rest of the list.

For more information, here's the list of the patches I applied on my system:

   100982-02   100985-04   100992-02   100999-22   101014-04
   101018-02   101025-05   101031-01   101039-06   101090-01
   101109-02

(BTW: this list has been recently published in this newsgroup, but I can't
remember who posted it: Thank you very much, anyway).

>Bill Wisner <[email-masked]> Gryphon Gang Mountain View CA 94039-0386

Luca Polo.

---
______Luca Polo___System administrator___Universita` di Padova___Italia________
(opinions expressed above are only mine, though  I can't exclude that somewhere
in the Universe someone (something ?) is crazy enough to share them...)
^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^v^

---

From: [email-masked] (Casper H.S. Dik)
Date: 3 Sep 1993 11:10:59 GMT

>"patch # XXXX, release YY", but I may be wrong.

Quite right. Instead of issuing new patches all the time, Sun issues patches
with a release number. If you request patch #xxxx from Sun, you'll get
xxxx-yy with the highest currently available yy.

The mandatory patchlist lists the patches current at the time of issue.
New patches and new versions will be issued all the time.

Use the version number of a patch to determine the lowest version number
that you should install.

Casper