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Abstract: To validate the reasonableness of a
numerical solution to a partial differential equation
on a given mesh, a common approach is to refine
the mesh, compute a solution on the finer mesh,
and compare the solutions on the two meshes.
Comparing graphical representations of the two so-
lutions gives a qualitative assessment of the solu-
tion quality. In many cases though, a priori er-
ror estimates from the theory of the finite element
method are available that provide quantitative pre-
dictions of the expected solution quality in terms
of the mesh spacing. This note shows how to use
tools available in COMSOL Multiphysics to com-
pute numerical estimates that can confirm if the
finite element method performs as predicted by the
theory. The technique presented does not assume
that the true solution of the PDE is known. It is
applied to linear Lagrange elements here, and ex-
tensions and limitations of the technique are dis-
cussed.
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1 Introduction

After successfully computing a numerical solution
to a partial differential equation (PDE) with some
software, say, a FEM solution with COMSOL Mul-
tiphysics, the attention typically shifts to the goal
of gaining confidence in the correctness and accu-
racy of the computed solution. If the solution is
computed on a given mesh, one common approach
is to refine the mesh uniformly, re-compute the so-
lution on the fine mesh, and compare the results on
both meshes graphically. This comparison of the
two solutions gives a qualitative assessment of cor-
rectness of the solution. To gain a quantitative as-

sessment of the accuracy of the solution, one option
is to use so-called a priori error estimates from the
theory of the finite element method (FEM) that
predict how the error should improve as the mesh
is refined. By applying these results repeatedly for
progressively smaller mesh spacings, one can as-
sess if the sequence of solutions is converging as
expected based on the theory.

For concreteness, consider a PDE on a spatial
domain Ω ⊂ R2 in two dimensions and let the
mesh spacing h denote the maximum side length
of the triangles in the mesh used to discretize the
domain Ω. A standard a priori error estimate for
the FEM solution uh predicts that the norm of its
error against the true solution u of the PDE satis-
fies

‖u− uh‖L2(Ω)
≤ C hq, as h → 0 (1.1)

with a constant C independent of h and the con-
vergence order q > 0. If the PDE and its domain
satisfy appropriate assumptions, discussed below,
the value of the exponent q in (1.1) depends on
the polynomial degree of the shape functions used
in the finite element space. For instance, for La-
grange elements with linear shape functions, the
theory predicts q = 2, that is, quadratic conver-
gence of the norm of the solution error.

The purpose of this paper is to explain how to
obtain a numerical confirmation that a FEM solu-
tion computed by COMSOL Multiphysics actually
behaves as predicted by (1.1) with q = 2 for lin-
ear Lagrange elements. Since this behavior is only
present if both PDE and the FEM satisfies cer-
tain assumptions, this method can also be used to
either confirm that the problem and method be-
have correctly or demonstrate that the problem
is not as well-behaved as expected. To this end,
we will compute an estimate for q from numeri-
cal results by considering a sequence of FEM so-
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Table 1: Convergence study for the model problem
(1.3)–(1.4) using linear Lagrange elements.

r DOF Er Rr Qr

0 25 3.74e-003
1 85 1.01e-003 3.71 1.89
2 313 2.59e-004 3.90 1.96
3 1201 6.51e-005 3.98 1.99
4 4705 1.60e-005 4.07 2.02
5 18625 3.64e-006 4.40 2.14

lutions uh on meshes with progressively smaller h.
More specifically, starting from some initial mesh,
we will refine it uniformly repeatedly, which sub-
divides every triangle into four triangles. If h mea-
sures the maximum side length of all triangles, this
procedure halves the value of h in each refinement.
Then assuming that ‖u− uh‖L2(Ω)

= C hq, the er-
ror for the next coarser mesh with mesh spacing
2h is ‖u− u2h‖L2(Ω)

= C (2h)q = 2q C hq and their
ratio ‖u− u2h‖L2(Ω)

/‖u− uh‖L2(Ω)
= 2q. If r de-

notes the number of refinement levels from the ini-
tial mesh and Er := ‖u− uh‖L2(Ω)

, then Er−1 =
‖u− u2h‖L2(Ω)

and we can write Rr = Er−1/Er for
their ratio. The quantity Qr = log2(Rr) provides
us then with a computable estimate for q in (1.1),
as h → 0, provided the PDE and the FEM satisfy
appropriate assumptions. Table 1 lists the number
of degrees of freedom (DOF) along with the quan-
tities Er, Rr, and Qr for the example of a model
problem, specified below. The error decreases with
increasing level of mesh refinement, and the values
for Rr and Qr confirm that the PDE and FEM
with linear Lagrange elements behave as (1.1) with
q = 2, as predicted by the theory. To obtain re-
sults such as in Table 1 for any PDE, for which the
true solution u is not known, one classical tech-
nique is to use a numerical solution computed on
a finer mesh, here one with refinement level 6, as
reference solution.

The error estimate (1.1) is a classical result and
holds under appropriate assumptions on the PDE
and its domain and on the finite elements both
for elliptic and parabolic problems. For elliptic
PDEs such as the Poisson equation −4u = f , the
classical assumption is that f ∈ L2(Ω), see, e.g.,
[1, Corollary II.7.7]. For parabolic PDEs such as
the heat equation ut − 4u = f , the assumption
f ∈ L2(Ω) also suffices and (1.1) applies in the
sense of the solution at every point in time, see,

e.g., [3, Theorem 1.3]. Here, L2(Ω) denotes the
function space of square-integrable functions, that
is, those functions v defined on the domain Ω for
which

∫
Ω

v2 dx < ∞. The error estimate (1.1) uses
its associated norm defined as

‖v‖
L2(Ω)

:=
(∫

Ω

v2 dx
)1/2

(1.2)

for all v ∈ L2(Ω). The assumptions on the domain
needed for the classical theory include that Ω be
open, bounded, convex, and simply connected, and
that its boundary ∂Ω be piecewise smooth. The as-
sumption on the boundary is easiest satisfied if Ω is
a polygonal domain such that it can be subdivided
into a union of triangles to form a triangulation Th

with mesh spacing h as defined above.
Note that it still makes sense to employ the con-

vergence test described in the following, even if
some of these assumptions are violated, because
it provides a quantitative gauge for how badly the
violated assumption in fact degrades the conver-
gence, if at all. For instance, the textbook proofs
in [1, 3] require that the domain be convex and
simply connected. In practice, these assumptions
can often not be satisfied, e.g., for a domain with
a hole, but it is observed that the FEM can still
give qualitatively good results in many cases, and
computable estimates such as the ones in Table 1
are useful to assess this observation quantitatively.

The remainder of this paper explains in detail
how to obtain results such as in Table 1 for FEM
solutions computed by COMSOL Multiphysics,
without assuming that the true solution of the
PDE is known. Specifically, Section 2 explains how
to use the graphical user interface (GUI) of COM-
SOL Multiphysics to create a m-file getfem.m that
solves the PDE under consideration for a desired
refinement level r. As model problem for the m-file,
we consider the default problem for the stationary
PDE mode in COMSOL Multiphysics, that is, the
Poisson equation with right-hand side f ≡ 1 with
homogeneous Dirichlet boundary conditions

−4u = 1 in Ω, (1.3)
u = 0 on ∂Ω, (1.4)

on the unit square Ω = (0, 1)2 ⊂ R2. The m-file
getfem can then be called repeatedly for each de-
sired refinement level from a driver script run in
COMSOL Script that computes the data needed
for Table 1, as shown in Section 3. Finally, Sec-
tion 4 discusses extensions and limitations of the
approach presented in this paper.
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2 The Function getfem

We first need to create an m-file getfem that solves
the desired PDE on a mesh obtained from an ini-
tial mesh by a number of mesh refinements r. To
solve, for example, the model problem (1.3)–(1.4)
using the GUI of COMSOL Multiphysics, select
in the Model Navigator the problem dimension 2D
and COMSOL Multiphysics→ PDE Modes→ Co-
efficient Form → Stationary Analysis. In the draw
mode of the GUI, draw the desired domain, here
the unit square Ω = (0, 1)2. (At this point, it
is convenient to use Options → Zoom → Zoom
Extents to re-center the GUI window.) For the
example (1.3)–(1.4), all other PDE and boundary
coefficients are at their default values. Also in the
case that you are solving any other PDE than this
model problem, I am assuming now that you have
also used the GUI of COMSOL Multiphysics to
obtain a preliminary solution.

To proceed towards confirming convergence of
the linear Lagrange elements, ensure first that
these elements are selected in COMSOL Multi-
physics. To do this, select Physics → Subdo-
main Settings, highlight the subdomain and then
select in the Element tab the elements labeled
Lagrange—Linear.

Mesh (or re-mesh if you already have a mesh) the
domain with a coarse initial mesh, so that we can
use several refinement levels later, as follows. In
Mesh → Free Mesh Parameters, choose Predefined
mesh size as Extremely coarse. When I re-meshed
now for the unit square Ω = (0, 1)2, I have got a
mesh with 36 elements. The fewer elements now,
the more refinements we can perform in the con-
vergence study and thus get more data in the table
in the end.

I suggest to select Mesh → Refine Mesh once at
this point, which gave me 144 triangular elements.
This step is suggested to get the meshrefine com-
mand into the m-file that we will export later.
Mesh → Mesh Statistics confirms that we have
85 degrees of freedom (DOF) as well as 85 mesh
points, thus confirming the linear Lagrange ele-
ments, which have one DOF per node. Notice that
this is the value for the DOF in Table 1 for refine-
ment level r = 1.

Now, have COMSOL solve the problem by se-
lecting the solution icon (the = sign) or in another
way. This also causes COMSOL to display the
solution. The solution in 3-D view using default
settings is shown in Figure 1. (To assemble this

Figure 1: Solution to (1.3)–(1.4).

manuscript, the plot was saved to file by File →
Export → Image in TIFF format.)

At this point, create the m-file by saving the en-
tire interactive session in the GUI up to this point
using File → Save As. After selecting m-file in the
Files of Type field, navigate to a desired directory
and provide the File Name getfem.m.

You can now start COMSOL Script and run the
script that was just saved to confirm that you get
exactly the same result as from the GUI. Specifi-
cally, either start COMSOL Script from the GUI
in File → COMSOL Script, or exit the GUI and
start COMSOL Script itself without the GUI. The
solution log will state the number of degrees of free-
dom, which helps confirm, in addition to checking
the plot displayed, that the problem was solved on
the same mesh.

At this point, we have a script file getfem.m
that solves the problem exactly as the GUI. We
now wish to modify it to obtain a function that
solves the problem for a desired refinement level
r = 0, 1, . . ., which is input as variable nref. To
this end, edit the file getfem.m as follows:

• In the first line of the file, insert the function
header

function fem = getfem (nref)

This means that the function will accept nref
as input variable and return the FEM struct
fem to the calling driver routine.

• Search for the call to meshrefine in function
getfem.m, and enclose it in a for-loop that
counts nref many refinement levels, yielding
the following code:.
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% Refine mesh
for nr = 1 : nref
fem.mesh=meshrefine(fem, ...

’mcase’,0, ...
’rmethod’,’regular’);

end;

Notice that a value of 0 for nref is legitimate
and means that no refinement takes place, as
the for-loop has an empty counter range.

• Delete (or comment out) the unneeded com-
mands at the end of getfem.m, namely the
line fem0=fem and all plot commands such as
postplot. For the model problem (1.3)–(1.4),
the call to femstatic that computes the FEM
struct fem should be the final line of code in
getfem.

After these edits, getfem.m is a function that we
can call from a driver routine to solve the desired
PDE using a mesh obtained by refining the ini-
tial mesh nref times. It returns the FEM struct
fem to the calling routine, which contains all data
of the problem, in particular the mesh points and
the solution. The complete function getfem.m for
the example of the model problem (1.3)–(1.4) is
printed in the following. (Some line breaks and
spacings of some code segments have been slightly
edited here to fit the space available.)

function fem = getfem (nref)

% COMSOL Multiphysics Model M-file
% Generated by COMSOL 3.3
% (COMSOL 3.3.0.405,
% $Date: 2006/08/31 18:03:47 $)

flclear fem

% COMSOL version
clear vrsn
vrsn.name = ’COMSOL 3.3’;
vrsn.ext = ’’;
vrsn.major = 0;
vrsn.build = 405;
vrsn.rcs = ’$Name: $’;
vrsn.date = ...

’$Date: 2006/08/31 18:03:47 $’;
fem.version = vrsn;

% Geometry
g1=rect2(1,1, ...

’base’,’corner’,’pos’,[0,0]);

% Analyzed geometry
clear s
s.objs={g1};
s.name={’R1’};
s.tags={’g1’};

fem.draw=struct(’s’,s);
fem.geom=geomcsg(fem);

% Initialize mesh
fem.mesh=meshinit(fem, ...

’hauto’,9);

% Refine mesh
for nr = 1 : nref
fem.mesh=meshrefine(fem, ...

’mcase’,0, ...
’rmethod’,’regular’);

end;

% (Default values are not included)

% Application mode 1
clear appl
appl.mode.class = ’FlPDEC’;
appl.assignsuffix = ’_c’;
clear prop
prop.elemdefault=’Lag1’;
appl.prop = prop;
clear bnd
bnd.type = ’dir’;
bnd.ind = [1,1,1,1];
appl.bnd = bnd;
fem.appl{1} = appl;
fem.frame = {’ref’};
fem.border = 1;
clear units;
units.basesystem = ’SI’;
fem.units = units;

% Multiphysics
fem=multiphysics(fem);

% Extend mesh
fem.xmesh=meshextend(fem);

% Solve problem
fem.sol=femstatic(fem, ...

’solcomp’,{’u’}, ...
’outcomp’,{’u’});
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3 The Driver Script

The script driver_getfem performs the conver-
gence study by calling the function getfem on pro-
gressively finer meshes, up to a maximum refine-
ment level set in nrefmax, that computes the data
reported in Table 1. The script is listed in its en-
tirety here, followed by explanations of several key
aspects.

% set the max. number of refinements:
nrefmax = 6;

% reference solution on finest mesh:
fem_ref = getfem (nrefmax);

% obtain mass matrix for finest mesh:
fema = fem_ref;
fema.equ.c = 0;
fema.equ.a = 1;
fema.xmesh = meshextend (fema);
[Mass,L,M,N] = assemble (fema);
p_ref = fema.mesh.p;
clear fema; % clear to save memory

% interpolate ref. sol. to ref. mesh:
u_ref = postinterp(fem_ref, ’u’, p_ref);

% preallocate vectors:
D = repmat (NaN, [nrefmax 1]);
E = repmat (NaN, [nrefmax 1]);

for nref = 0 : nrefmax-1
fem = getfem (nref);
D(nref+1) = length(fem.sol.u);

% interpolate sol. to ref. mesh:
u_int = postinterp(fem, ’u’, p_ref);

% compute error as a column vector:
e = u_ref(:) - u_int(:);

% compute L2-norm of nodal error:
E(nref+1) = sqrt(e’*Mass*e);

end;

R = E(1:nrefmax-1) ./ E(2:nrefmax);
Q = log2(R);

The script starts by setting nrefmax to the de-
sired maximum refinement level that controls the
finest mesh used. The call to getfem computes

the FEM solution on this mesh. This reference so-
lution is used in place of the true solution in the
error u− uh. This is a standard technique in con-
vergence studies in the typical case that the true
solution for the PDE is not known. For the model
problem (1.3)–(1.4), the refinement level 6 leads to
74113 degrees of freedom (DOF). On a computer
with an Intel Xeon 2.0 GHz CPU, the calculation
on this mesh took less than 15 seconds including
all startup. A memory usage of 145 MB was ob-
served this mesh, making this the finest mesh solv-
able with the 512 MB of available memory.

The following commands in the driver script ob-
tain a mass matrix and nodes of the reference
mesh. The matrix needed in the norm computa-
tions later in the script has elements

Mk` =
∫

Ω

ϕk(x) ϕ`(x) dx (3.1)

defined in terms of the FEM basis functions ϕk(x)
associated with all degrees of freedom. I use COM-
SOL Multiphysics here to compute this matrix in
variable Mass by assembling an auxiliary finite el-
ement discretization in the struct fema for a PDE
with the problem coefficients specifically chosen to
compute Mk` in (3.1).

Next, the reference solution in the FEM struct
fem_ref is formally interpolated to the nodes
p_ref of the reference mesh. This amounts to a
re-ordering and is necessary, because the order of
components in the solution vector fem_ref.sol.u
does not agree with the ordering of the nodes in
p_ref.

The for-loop is the heart of the script and com-
putes the FEM solutions for the desired refinement
levels from 0 to nrefmax-1 by calling the function
getfem for each refinement level. For the linear
Lagrange elements, the length of the solution vec-
tor is the number of DOF, which are saved in the
vector D. After the solution in the FEM struct fem
is interpolated to the nodes of the reference mesh,
the nodal error against the reference solution is
computed in vector e; the use of the colon : in the
arguments of the vectors makes e a column vector.

To compute the L2-norm of the error, we use the
fact that a FEM solution is given in terms of the
FEM basis functions ϕk(x) by the expansion

uh =
N∑

k=1

uk ϕk(x), (3.2)

where N denotes the number of degrees of freedom.
For linear Lagrange elements, the expansion coeffi-
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cients uk are the solution values at the nodes of the
mesh. Therefore, the FEM error eh = u− uh also
has an expansion of the form (3.2) and its expan-
sion coefficients ek are exactly the nodal errors in
the components of the vector e. The connection to
the mass matrix with elements Mk` defined above
becomes clear after using the representation of eh

in the norm definition (1.2), which gives

‖eh‖L2(Ω)
=

(
N∑

k=1

N∑
`=1

ekMk`e`

)1/2

. (3.3)

Thus the computation of the double sum can be
programmed as e’*Mass*e, for which we need e
to be a column vector.

Finally, the last two lines of the driver script
compute the vectors R and Q from the errors in
E. Using format compact and format long, the
COMSOL Script window shows the following re-
sults for the model problem, which is the raw data
for Table 1.

C>> driver_getfem
C>> D
D =

25
85
313

1201
4705
18625

C>> E
E =

0.00373991924891
0.00100787252430

2.58724778510e-004
6.50628338773e-005
1.59880180888e-005
3.63752316794e-006

C>> R
R =

3.71070662088152
3.89553922936714
3.97653718862375
4.06947462256785
4.39530343879178

C>> Q
Q =

1.89169394193255
1.96182304322636
1.99151266309084
2.02484255165592
2.13596276821933

4 Extensions and Limitations

We showed a procedure for estimating the conver-
gence order of the FEM solution in the L2-norm us-
ing COMSOL Multiphysics and COMSOL Script.
We demonstrated the procedure for a stationary
PDE in two spatial dimensions. The same proce-
dure can be applied to transient PDEs at several
chosen points in time, as used in [2]. It can also
be readily used in other space dimensions. The a
priori error estimate in (1.1) also holds for quadri-
lateral meshes and the proposed procedure general-
izes to these elements. Due to the abstract formu-
lation of the norm computation, these generaliza-
tions usually only involve modifications in getfem
in the way the meshes are initialized and/or re-
fined.

The assembly of the mass matrix as given in the
driver script uses coefficient names that are spe-
cific to the PDE Modes in COMSOL Multiphysics.
The approach should work in principle for other
modes with appropriate changes of variable names,
including the mode dependent name of the solution
variable.

However, the specific procedure suggested to
compute the L2-norm of the error between the
FEM approximation and a reference solution re-
lied on the use of linear Lagrange elements to
guarantee that the error has an expansion of the
form (3.2) with nodal errors as expansion coeffi-
cients. The approach can be somewhat generalized
to quadratic Lagrange elements by using the nodes
and mass matrix associated with another uniform
refinement of the auxiliary mesh. However, a bet-
ter approach might exist that both uses COMSOL
Multiphysics more effectively and can be used for
all types of finite elements available.
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